Помогите написать алгоритм бинарного дерева в Excel для игры «Угадай животное»!

Помогите написать алгоритм бинарного дерева в Excel для игры "Угадай животное"!
Нужно сделать так чтобы само дерево отображалось в таблице и с каждым новым животным "разросталось"!

  • если у вас хорошее воображение, то вы увидите бинарное дерево:

    а вот формула которая стоит во всех ячейках:
    =ЕСЛИ(ПСТР($A$1;СТРОКА()-1;1)=ПСТР("йцукенгшщзхъфывапролджэячсмитьбюё";СТОЛБЕЦ();1);ПСТР("йцукенгшщзхъфывапролджэячсмитьбюё";СТОЛБЕЦ();1);"-")

    в виду того , что я не знаю как играть в игру "угадай животное", я в таблице заложил (бинарный)алгоритм;
    первая буква слова А ?
    если нет
    первая буква слова Б ?
    ....
    ....
    пятая буква слова А ?
    пятая буква слова Б ?
    ...
    пятая буква слова Я ? ;) ;) ;)
    и выложу таки увеличенную картинку

  • http://info-comp.ru/